APN Not Working after Changing the SIM card

Problem

The SIM card was changed in an Android device owner device and now the mobile network is not working even tough an APN profile is installed.

Cause

An APN profile is linked and locked to the SIM card. You can not just change the SIM card or set the profile to waiting. The APN profile is still locked to the old SIM card.

Solution

You need to remove the APN profile from the device before you can insert the new SIM card and link the APN profile again.

Make sure you have CapaInstaller Android Agent 2.2.15 or newer installed.


It's important you follow this step-to-stop guide!

NB! Make sure you are connected to WiFi before removing the profile or SIM card!

  1. Remove the APN profile from the device in CapaInstaller Console Configuration Management and wait until it's removed from the device.
  2. Remove the old SIM card
  3. Insert the new SIM card
  4. Apply the APN profile again in the console on the device and wait until it's installed.



APN profile is supported by Android 9 and newer device owner.